A Microsoft Office (Excel, Word) forum. OfficeFrustration

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » OfficeFrustration forum » Microsoft Access » Database Design
Site Map Home Register Authors List Search Today's Posts Mark Forums Read  

Slow running reports



 
 
Thread Tools Display Modes
  #1  
Old April 27th, 2010, 01:16 PM posted to microsoft.public.access.tablesdbdesign
Kieran H
external usenet poster
 
Posts: 2
Default Slow running reports

I'm running an Access based reporting application in two
environments. The older, MS Access 2000 version has been running for
years without issue. If I run the same report in both I get the
timing results below.

Please note that for this example the pass-through query runs in
approximately the same time on both versions circa 3-4 seconds and is
only returning 40 rows of data.

My question is why is MS Access 2007 taking 16 seconds to render the
report. I fully appreciate the devil is in the detail, I am just
wondering whether there are known issues that would explain this
behaviour.

(Just to make things interesting if the query is run as a maketable
query and the report is pointed at the newly created table if both
events are sequenced it will also run in circa 8 seconds. Currently
the report uses the pass-through query as the data source)


MS Access 2000
Windows 2000 & XP (mixed)

Reporting application captures report type & report parameters and
calls SQL Server 7 stored procedure for required data

Data returned to MS Access and rendered in MS Acccess report

Report takes between 6-8 seconds to render report

MS Access 2007
Windows XP

Reporting application captures report type & report parameters and
calls SQL Server 7 stored procedure for required data

Data returned to MS Access and rendered in MS Acccess report

Report takes between 16-18 seconds to render report!

Any thought would be appreciated

Cheers

Kieran




Ads
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 12:15 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2004-2018 OfficeFrustration.
The comments are property of their posters.