A Microsoft Office (Excel, Word) forum. OfficeFrustration

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » OfficeFrustration forum » Microsoft Access » Setting Up & Running Reports
Site Map Home Register Authors List Search Today's Posts Mark Forums Read  

PageSetup properties keep changing



 
 
Thread Tools Display Modes
  #1  
Old June 7th, 2010, 02:41 PM posted to microsoft.public.access.reports
PayeDoc
external usenet poster
 
Posts: 103
Default PageSetup properties keep changing

Hello All

I recently had some mdb corruption problems, that I THINK I've solved - by
creating a new mdb and importing all objects. A new problem has now started
that is either coincidental or is somehow related to my having done the mdb
rebuild.

The page setup properties of various reports changes, periodically, 'by
iteslf'! I have been able to repeat this behaviour to some extent:

1. preview report - discover that the page setup properties are completely
wrong
2. close the report
3. select the report in the main database window, go FilePage Setup,
correct the properties
4. preview report - the page setup properties are now ok
5. close the report
6. amend a parameter on the open form that is used by the report
7. preview report - discover that the page setup properties are completely
wrong again!

This doesn't always happen, and I have been unable to identify any pattern.
The page setup properties are the margins, the landscape/portrait setting,
and in one case the printer - changed from 'specified printer (correct) to
default printer (not corect). I had been advised that setting the page setup
properties from the File menu item in the main database window was more
reliable than setting them from the report's design view - hence step 3
above.

Can anyone shed any light on this?

Thanks for any help.
Leslie Isaacs


  #2  
Old June 7th, 2010, 03:22 PM posted to microsoft.public.access.reports
Allen Browne
external usenet poster
 
Posts: 11,706
Default PageSetup properties keep changing

Make sure Name AutoCorrect is turned off.
Then compact the database.
Explanation:
http://allenbrowne.com/bug-03.html

If this is Access 2007, make sure you have applied the service packs. SP2 is
he
http://www.microsoft.com/downloads/d...displaylang=en

--
Allen Browne - Microsoft MVP. Perth, Western Australia
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.


"PayeDoc" wrote in message
...
Hello All

I recently had some mdb corruption problems, that I THINK I've solved - by
creating a new mdb and importing all objects. A new problem has now
started
that is either coincidental or is somehow related to my having done the
mdb
rebuild.

The page setup properties of various reports changes, periodically, 'by
iteslf'! I have been able to repeat this behaviour to some extent:

1. preview report - discover that the page setup properties are completely
wrong
2. close the report
3. select the report in the main database window, go FilePage Setup,
correct the properties
4. preview report - the page setup properties are now ok
5. close the report
6. amend a parameter on the open form that is used by the report
7. preview report - discover that the page setup properties are completely
wrong again!

This doesn't always happen, and I have been unable to identify any
pattern.
The page setup properties are the margins, the landscape/portrait setting,
and in one case the printer - changed from 'specified printer (correct) to
default printer (not corect). I had been advised that setting the page
setup
properties from the File menu item in the main database window was more
reliable than setting them from the report's design view - hence step 3
above.

Can anyone shed any light on this?

Thanks for any help.
Leslie Isaacs


  #3  
Old June 7th, 2010, 03:57 PM posted to microsoft.public.access.reports
PayeDoc
external usenet poster
 
Posts: 103
Default PageSetup properties keep changing

Hello Allen

Very many thanks for your response to this. I am using Access 2000, and I
have found that the Name AutoCorrect was turned on: it's now off!

I note from your reference that you suggest creating a new mdb, turning off
Name AutoCorrect, then inporting all objects. Is that really going to be
better than just turning the feature off then doing a compact/repair?

Thanks again
Les



"Allen Browne" wrote in message
...
Make sure Name AutoCorrect is turned off.
Then compact the database.
Explanation:
http://allenbrowne.com/bug-03.html

If this is Access 2007, make sure you have applied the service packs. SP2

is
he

http://www.microsoft.com/downloads/d...displaylang=en

--
Allen Browne - Microsoft MVP. Perth, Western Australia
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.


"PayeDoc" wrote in message
...
Hello All

I recently had some mdb corruption problems, that I THINK I've solved -

by
creating a new mdb and importing all objects. A new problem has now
started
that is either coincidental or is somehow related to my having done the
mdb
rebuild.

The page setup properties of various reports changes, periodically, 'by
iteslf'! I have been able to repeat this behaviour to some extent:

1. preview report - discover that the page setup properties are

completely
wrong
2. close the report
3. select the report in the main database window, go FilePage Setup,
correct the properties
4. preview report - the page setup properties are now ok
5. close the report
6. amend a parameter on the open form that is used by the report
7. preview report - discover that the page setup properties are

completely
wrong again!

This doesn't always happen, and I have been unable to identify any
pattern.
The page setup properties are the margins, the landscape/portrait

setting,
and in one case the printer - changed from 'specified printer (correct)

to
default printer (not corect). I had been advised that setting the page
setup
properties from the File menu item in the main database window was more
reliable than setting them from the report's design view - hence step 3
above.

Can anyone shed any light on this?

Thanks for any help.
Leslie Isaacs




 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 03:50 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2004-2018 OfficeFrustration.
The comments are property of their posters.